PHPKB Knowledge Base Software Logo  
Guru Corner
Online Knowledgebase System  
Knowledge Base Home Knowledge Base Home
Home > All Categories > Cisco Systems > Routing > OSPF > OSPF Network Types and Frame Relay - Part 1
Question Title OSPF Network Types and Frame Relay - Part 1

Knowing the OSPF Network Types and how they work with different frame relay topologies is one of those things that you should know inside out if you are attempting the CCIE lab. In this next series of articles we will be looking at the 5 OSPF network as well as how and when to use them in conjunction with a frame relay hub and spoke topology.

We will be using the following topology for this tutorial:

OSPF and Frame Relay Topology

Dynagen Configuration

ghostios = True
sparsemem = True
model = 3640

[localhost]

    [[3640]]
        image = \Program Files\Dynamips\images\c3640-jk9o3s-mz.124-12.bin
        # On Linux / Unix use forward slashes:
        # image = /opt/7200-images/c7200-jk9o3s-mz.124-7a.image
        ram = 96

    [[ROUTER R1]]
        f0/0 = LAN 1
        s1/0 = FRAME 1
        console = 2000
        model = 3640

    [[ROUTER R2]]
        f0/0 = LAN 2
        s1/0 = FRAME 2
        console = 2001
        model = 3640

    [[ROUTER R3]]
        f0/0 = LAN 3
        s1/0 = FRAME 3
        console = 2002
        model = 3640

    [[FRSW FRAME]]
        1:102 = 2:201
        1:103 = 3:301
    

Basic Configuration

First things first lets set up our hub and spoke frame-relay topology. You can see in the diagram above R1 will be our hub, and R2 and R3 will be our spokes.

R1

hostname R1
!
interface fastEthernet0/0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.2 102 broadcast
 frame-relay map ip 192.168.1.3 103 broadcast
 no frame-relay inverse-arp

R2

hostname R2
!
interface fastEthernet0/0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 201 broadcast
 frame-relay map ip 192.168.1.3 201
 no frame-relay inverse-arp

R3

hostname R3
!
interface fastEthernet0/0
 ip address 3.3.3.3 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 301 broadcast
 frame-relay map ip 192.168.1.2 301
 no frame-relay inverse-arp

We have disabled frame-relay inverse arp, and made sure that R1 does not recieve redundant network broadcasts.

OSPF Over Frame Relay - Non-Broadcast Network Type

The Non-Broadcast network types is used for topologies with no broadcast capability (or no broadcast capability configured!), or in topologies where you want OSPF to unicast its updates instead of broadcasting/multicasting. In the topology and configuration shown above we have configured the pseudo-broadcast capability of frame-relay. It doesnít really broadcast because not all stations in the cloud will receive that, just the ones with the broadcast statement in the frame-relay map command.

Lets have a look our configuration for Non-Broadcast Frame-Relay networks:

R1

hostname R1
!
interface fastEthernet0/0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.2 102
 frame-relay map ip 192.168.1.3 103
 no frame-relay inverse-arp
 ip ospf network non-broadcast
!
router ospf 1
 router-id 1.1.1.1
 network 0.0.0.0 255.255.255.255 area 0
 neighbor 192.168.1.2
 neighbor 192.168.1.3

R2

hostname R2
!
interface fastEthernet0/0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 201
 frame-relay map ip 192.168.1.3 201
 no frame-relay inverse-arp
 ip ospf network non-broadcast
 ip ospf priority 0
!
router ospf 1
 router-id 2.2.2.2
 network 0.0.0.0 255.255.255.255 area 0

R3

hostname R3
!
interface fastEthernet0/0
 ip address 3.3.3.3 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 301
 frame-relay map ip 192.168.1.2 301
 no frame-relay inverse-arp
 ip ospf network non-broadcast
 ip ospf priority 0
!
router ospf 1
 router-id 3.3.3.3
 network 0.0.0.0 255.255.255.255 area 0

You can see in the code above that we have disabled the broadcast capability of Frame-Relay by removing the broadcast statement from the frame-relay map statements.

When preparing for your CCIE, its important to be able to look at the above topology and recognise when potential problems might arise. OSPF network type Non-Broadcast requires a DR. I would recognise that R1 is the hub and should be made the DR in OSPF network types that require them. OSPF Non-Broadcast is one of our only options here (the other being the Point-to-Multipoint Non-Broadcast) as we have no capability to broadcast over that segment.

We have made sure that the spokes (R2 & R3) are ineligible to become the DR. We can use the ip ospf priority 0 over the frame-relay topology thereby ensuring R1 will become the DR for the segment. On R1 we have specified our neighbors to unicast routing updates to using the neighbor command.

Lets verify the configuration:

R1#
*Mar  1 00:08:47: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/0 from LOADING to FULL, Loading Done
*Mar  1 00:08:47: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/0 from LOADING to FULL, Loading Done
R1#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/DROTHER    00:01:56    192.168.1.2     Serial1/0
3.3.3.3           0   FULL/DROTHER    00:01:55    192.168.1.3     Serial1/0

Looks like our neighbours have been brought up, lets check our routing table:

R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
O       1.1.1.0 [110/65] via 192.168.1.1, 00:00:55, Serial1/0
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, FastEthernet0/0
     3.0.0.0/24 is subnetted, 1 subnets
O       3.3.3.0 [110/65] via 192.168.1.3, 00:00:55, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0

We have a route to R1, and R3ís f0/0 networks in R2ís routing table so R2 should have full reachability to those networks.

R2#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/153/248 ms
R2#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 144/249/376 ms

Looks like we have full reachability. Lets verify the OSPF timers and network types. We can do this with the show ip ospf interface command.

R1#sh ip ospf int
Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 192.168.1.1
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:19
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 2.2.2.2
    Adjacent with neighbor 3.3.3.3
  Suppress hello for 0 neighbor(s)
FastEthernet0/0 is up, line protocol is up
  Internet Address 1.1.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 1.1.1.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:09
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

You can see the default timers on the Serial interface is 30 seconds for the Hello packets with a dead interval of 120 seconds. On a Fast Ethernet interface the default timers are 10 seconds and 40 seconds for hello and dead intervals respectively. In fact Cisco uses a default of Hello interval of 10 seconds for all broadcast networks and 30 seconds for non-broadcast. A dead interval is 4x this value. These values can be changed with the ip ospf hello interval command. OSPF network type non-broadcast is the default network type if you are using a physical serial interface.

OSPF Over Frame Relay - Broadcast Network Type

The Broadcast Network type is the default network type on an Ethernet interface. A DR is election is performed and updates are sent via multicast packets. Frame relay will need to be configured for broadcast support to support the network type.

Lets have a look at the configuration:

R1

hostname R1
!
interface fastEthernet0/0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.2 102 broadcast
 frame-relay map ip 192.168.1.3 103 broadcast
 no frame-relay inverse-arp
 ip ospf network broadcast
!
router ospf 1
 router-id 1.1.1.1
 network 0.0.0.0 255.255.255.255 area 0

R2

hostname R2
!
interface fastEthernet0/0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 201 broadcast
 frame-relay map ip 192.168.1.3 201
 no frame-relay inverse-arp
 ip ospf network broadcast
 ip ospf priority 0
!
router ospf 1
 router-id 2.2.2.2
 network 0.0.0.0 255.255.255.255 area 0

R3

hostname R3
!
interface fastEthernet0/0
 ip address 3.3.3.3 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 301 broadcast
 frame-relay map ip 192.168.1.2 301
 ip ospf priority 0
 no frame-relay inverse-arp
 ip ospf network broadcast
!
router ospf 1
 router-id 3.3.3.3
 network 0.0.0.0 255.255.255.255 area 0

You can see above that the frame-relay map commands have the broadcast keywords added. If we use the OSPF broadcast network type, we have to make sure that our layer two topology supports broadcasts. Lets verify the configuration:

R1#
*Mar  1 01:17: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/0 from LOADING to FULL, Loading Done
*Mar  1 01:17: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/0 from LOADING to FULL, Loading Done

R1#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/DROTHER    00:00:34    192.168.1.2     Serial1/0
3.3.3.3           0   FULL/DROTHER    00:00:34    192.168.1.3     Serial1/0
R1#sh run

If we have a look at the neighbors on R3, or R2 we should see that the only neighbour relationship formed is with the DR (R1 in this case).

R3#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DR         00:00:31    192.168.1.1     Serial1/0

Looks like our neighbours have been brought up, lets check our routing table:

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
O       1.1.1.0 [110/65] via 192.168.1.1, 00:09:29, Serial1/0
     2.0.0.0/24 is subnetted, 1 subnets
O       2.2.2.0 [110/65] via 192.168.1.2, 00:09:29, Serial1/0
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, Serial1/0
R3#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 136/176/220 ms
R3#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 236/283/340 ms

You can see above, that even though R3 has no neighbour relationship with R2 we can still reach R2ís ethernet segment. We are learning this through the Designated Router R1. R1 is acting as a co-ordination point. R2 and R3 will send their updates to R1. R1 will collate these updates and distribute them out to the spokes. Hence why R2 and R3 only need to have a neighbor relationship with the DR.

Lets have a look at the timers and verify the network type:

R1#sh ip ospf int
Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 192.168.1.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 2.2.2.2
    Adjacent with neighbor 3.3.3.3
  Suppress hello for 0 neighbor(s)
FastEthernet0/0 is up, line protocol is up
  Internet Address 1.1.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 1.1.1.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

Notice above how the hello and dead intervals are 10 and 40 seconds respecitively for both the ethernet and serial interfaces. As mentioned above, this is because CISCO uses a default Hellp Interval for broadcast networks and 30 seconds for non-broadcast. The OSPFv2 RFC 2328 doesnít really have a required value for either Hello or Dead intervals but does suggest a hello interval of 10 seconds and a dead interval of 4X the hello interval.

Thatís it for broadcast and non-broadcast networks.

Summary:

  • Non-Broadcast network type is the default on a physical serial interface with ospf configured
  • Non-Broadcast networks send unicast packets, so must be configured with neighbor statements
  • Non-Broadcast networks have Hello and Dead intervals of 30 seconds and 120 seconds respectively
  • Broadcast network types is the default on an ethernet interface.
  • Broadcast network types must support broadcasting capability on a layer 2 topology
  • Non-Broadcast and Broadcast network types require a DR. Care should be taken in DR placement (should be the Hub).

We will be continuing our OSPF Network Type series of articles by looking at Point-to-Multipoint and Point-to-Multipoint Non-Broadcast network types.

Once again, we will be using the following topology for this tutorial:

OSPF and Frame Relay Topology

Dynagen Configuration

ghostios = True
sparsemem = True
model = 3640

[localhost]

    [[3640]]
        image = \Program Files\Dynamips\images\c3640-jk9o3s-mz.124-12.bin
        # On Linux / Unix use forward slashes:
        # image = /opt/7200-images/c7200-jk9o3s-mz.124-7a.image
        ram = 96

    [[ROUTER R1]]
        f0/0 = LAN 1
        s1/0 = FRAME 1
        console = 2000
        model = 3640

    [[ROUTER R2]]
        f0/0 = LAN 2
        s1/0 = FRAME 2
        console = 2001
        model = 3640

    [[ROUTER R3]]
        f0/0 = LAN 3
        s1/0 = FRAME 3
        console = 2002
        model = 3640

    [[FRSW FRAME]]
        1:102 = 2:201
        1:103 = 3:301

 

OSPF Over Frame Relay - Point-to-Multipoint Network Type

OSPF treats Point-to-Multipoint networks as a collection of point-to-point links. A DR/BDR is not required in these networks as OSPF Packets are unicast to known neighbors. Lets have a look at the configuration:

R1

hostname R1
!
interface fastEthernet0/0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.2 102 broadcast
 frame-relay map ip 192.168.1.3 103 broadcast
 no frame-relay inverse-arp
 ip ospf network point-to-multipoint
!
router ospf 1
 router-id 1.1.1.1
 network 0.0.0.0 255.255.255.255 area 0

R2

hostname R2
!
interface fastEthernet0/0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 201 broadcast
 frame-relay map ip 192.168.1.3 201
 no frame-relay inverse-arp
 ip ospf network point-to-multipoint
!
router ospf 1
 router-id 2.2.2.2
 network 0.0.0.0 255.255.255.255 area 0

R3

hostname R3
!
interface fastEthernet0/0
 ip address 3.3.3.3 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 301 broadcast
 frame-relay map ip 192.168.1.2 301
 no frame-relay inverse-arp
 ip ospf network point-to-multipoint
!
router ospf 1
 router-id 3.3.3.3
 network 0.0.0.0 255.255.255.255 area 0

You can see the configuration above is fairly straight forward. We donít need to worry about a DR as Point-to-Multipoint networks donít require one. Letís verify the configuration:

R1#
*Mar  1 00:03: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/0 from LOADING to FULL, Loading Done
*Mar  1 00:03: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/0 from LOADING to FULL, Loading Done
R1#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:01:39    192.168.1.2     Serial1/0
3.3.3.3           0   FULL/  -        00:01:39    192.168.1.3     Serial1/0

You can see the output of the show ip ospf neighbors command above. We have full adjacency with R2 and R3. You can also see that there is no DR/BDR relationship between any of the routers.

Lets verify the network types and timers:

Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.3/24, Area 0
  Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1
  Suppress hello for 0 neighbor(s)
FastEthernet0/0 is up, line protocol is up
  Internet Address 3.3.3.3/24, Area 0
  Process ID 1, Router ID 3.3.3.3, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 3.3.3.3, Interface address 3.3.3.3
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:04
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

You can see above the default timers on a Point-to-Multipoint network is 30 seconds and 120 seconds for the hello and dead intervals respectively. So far this looks not very different from the other network types other than the ip ospf network type command. Lets take a look more closely at R3 and R3ís routing table:

R3#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:01:42    192.168.1.1     Serial1/0

Looks like R3 has only formed a neighbor relationship with R1. Wait a minute, if R3 only forms a neighbor relationship with R1 and there is no DR relationship, does that mean that R3 has no idea about the networks from R2? The answer to this question lies in the route table of R3. Letís compare this to the route table when we used the Broadcast network type:

Route Table Using Point-to-Multipoint Network Type

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
O       1.1.1.0 [110/65] via 192.168.1.1, 00:10:26, Serial1/0
     2.0.0.0/24 is subnetted, 1 subnets
O       2.2.2.0 [110/129] via 192.168.1.1, 00:10:26, Serial1/0
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, FastEthernet0/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.1.1/32 [110/64] via 192.168.1.1, 00:10:26, Serial1/0
C       192.168.1.0/24 is directly connected, Serial1/0
O       192.168.1.2/32 [110/128] via 192.168.1.1, 00:10:26, Serial1/0

Route Table Using Broadcast Network Type

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
O       1.1.1.0 [110/65] via 192.168.1.1, 00:09:29, Serial1/0
     2.0.0.0/24 is subnetted, 1 subnets
O       2.2.2.0 [110/65] via 192.168.1.2, 00:09:29, Serial1/0
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, Serial1/0

If we compare the route tables, we see that the route table for Point-to-Multipoint has three differences:

O       2.2.2.0 [110/129] via 192.168.1.1, 00:10:26, Serial1/0
O       192.168.1.1/32 [110/64] via 192.168.1.1, 00:10:26, Serial1/0
O       192.168.1.2/32 [110/128] via 192.168.1.1, 00:10:26, Serial1/0

The route to 2.2.2.0 network is via 192.168.1.1 instead of 192.168.1.2. We also have two /32 routes for the endpoints in the frame-relay cloud.

The Point-to-Multipoint network type treats the NBMA network as a series of point-to-point links. OSPF treats it as if we are squeezing a single subnet over two point to point links. In this case all of R3ís routes are via R1. The layer 3 topology is mirroring the layer 2 topology.

Because Point-to-Multipoint treats the NBMA network as a series of point-to-point links, we could even get rid of the frame relay map between R3 and R2 and the routes should still be fine! Lets try it:

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#int s1/0
R3(config-if)#no frame-relay map ip 192.168.1.2 301
R3(config-if)#end
*Mar  1 01:59:25.239: %SYS-5-CONFIG_I: Configured from console by console
R3#sh run int s1/0
Building configuration...

Current configuration : 227 bytes
!
interface Serial1/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 301 broadcast
 no frame-relay inverse-arp
end

The configuration above shows we no longer have a mapping to R2. Letís have a look at the effect this has. Weíll clear the OSPF processes and take a look at reachability afterwards:

R3#clear ip ospf pro
Reset ALL OSPF processes? [no]: yes
R3#
*Mar  1 01:59: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial1/0 from FULL to DOWN,
Neighbor Down: Interface down or detached
*Mar  1 01:59: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial1/0 from LOADING to FULL, Loading Done
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
O       1.1.1.0 [110/65] via 192.168.1.1, 00:00:00, Serial1/0
     2.0.0.0/24 is subnetted, 1 subnets
O       2.2.2.0 [110/129] via 192.168.1.1, 00:00:00, Serial1/0
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, FastEthernet0/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.1.1/32 [110/64] via 192.168.1.1, 00:00:00, Serial1/0
C       192.168.1.0/24 is directly connected, Serial1/0
O       192.168.1.2/32 [110/128] via 192.168.1.1, 00:00:00, Serial1/0
R3#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/229/428 ms

This still works because the OSPF point-to-multipoint network introduced an extra hop between R3 and the ethernet network on R2. Instead of going straight to R2ís 192.168.1.2 address to get to that segment we go via R1ís 192.168.1.1. OSPF has inserted an extra hop via R1 to mirror that of the layer 2 topology! Cool huh?

OSPF Over Frame Relay - Point-to-Multipoint Non-Broadcast Network Type

The point-to-multipoint non-broadcast network type is basically the same as the point-to-multipoint network type except it is useful in scenarios where we have no broadcast capabilities. Lets reconfigure our layer 2 topology and take away the pseudo broadcast capability of frame relay:

R1

hostname R1
!
interface fastEthernet0/0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.2 102
 frame-relay map ip 192.168.1.3 103
 no frame-relay inverse-arp
 ip ospf network point-to-multipoint non-broadcast
!
router ospf 1
 router-id 1.1.1.1
 network 0.0.0.0 255.255.255.255 area 0
 neighbor 192.168.1.2
 neighbor 192.168.1.3

R2

hostname R2
!
interface fastEthernet0/0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 201
 frame-relay map ip 192.168.1.3 201
 no frame-relay inverse-arp
 ip ospf network point-to-multipoint non-broadcast
!
router ospf 1
 router-id 2.2.2.2
 network 0.0.0.0 255.255.255.255 area 0

R3

hostname R3
!
interface fastEthernet0/0
 ip address 3.3.3.3 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 301
 frame-relay map ip 192.168.1.2 301
 no frame-relay inverse-arp
 ip ospf network point-to-multipoint non-broadcast
!
router ospf 1
 router-id 3.3.3.3
 network 0.0.0.0 255.255.255.255 area 0

You will notice with the configuration above we have once again removed the broadcast statement from the frame-relay map statements so no broadcasts will be propogated across that network. R1 has R2 and R3 defined as its neighbors and will unicast updates to them. Lets verify the configuration:

R1#
*Mar  1 02:43: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/0 from LOADING to FULL, Loading Done
*Mar  1 02:43: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/0 from LOADING to FULL, Loading Done
R1#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:01:31    192.168.1.2     Serial1/0
3.3.3.3           0   FULL/  -        00:01:31    192.168.1.3     Serial1/0

Once again you can see that R1 has established adjacencies with R2 and R3. No DR/BDR relationship is established in a point-to-multipoint non-broadcast network. Lets verify the network type and timers:

R1#sh ip ospf int
Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:23
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 2.2.2.2
    Adjacent with neighbor 3.3.3.3
  Suppress hello for 0 neighbor(s)
FastEthernet0/0 is up, line protocol is up
  Internet Address 1.1.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 1.1.1.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

You can see the default timers for a point-to-multipoint non-broadcast network are 30 seconds and 120 seconds for the hello and dead intervals respectively.

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
O       1.1.1.0 [110/65] via 192.168.1.1, 00:20:04, Serial1/0
     2.0.0.0/24 is subnetted, 1 subnets
O       2.2.2.0 [110/129] via 192.168.1.1, 00:20:04, Serial1/0
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, FastEthernet0/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.1.1/32 [110/64] via 192.168.1.1, 00:20:04, Serial1/0
C       192.168.1.0/24 is directly connected, Serial1/0
O       192.168.1.2/32 [110/128] via 192.168.1.1, 00:20:05, Serial1/0

Looking at the routing table on R3, we can again see that the layer 3 routing mirrorís the layer 2 switching, with everything going through R1.

The other thing that differentiates point-to-multipoint from point-to-multipoint non-broadcast is the ability to define the costs of
routes originating from a particular neighbor.

For example:

router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
 neighbor 192.168.1.2 cost 100
 neighbor 192.168.1.3

Here we have defined all updates coming from R2 to have a cost of 100. Lets have a look at the routing table before and after this change:

Before:

R1(config-router)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
O       2.2.2.0 [110/65] via 192.168.1.2, 00:24:07, Serial1/0
     3.0.0.0/24 is subnetted, 1 subnets
O       3.3.3.0 [110/65] via 192.168.1.3, 00:24:07, Serial1/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Serial1/0
O       192.168.1.3/32 [110/64] via 192.168.1.3, 00:24:07, Serial1/0
O       192.168.1.2/32 [110/64] via 192.168.1.2, 00:24:07, Serial1/0

After:

R1(config-router)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
O       2.2.2.0 [110/101] via 192.168.1.2, 00:00:02, Serial1/0
     3.0.0.0/24 is subnetted, 1 subnets
O       3.3.3.0 [110/65] via 192.168.1.3, 00:00:02, Serial1/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Serial1/0
O       192.168.1.3/32 [110/64] via 192.168.1.3, 00:00:02, Serial1/0
O       192.168.1.2/32 [110/100] via 192.168.1.2, 00:00:02, Serial1/0

You can see the route cost to the networks that R2 updated were increased to 100 (directly connected 192.168.1.2), and 101 (2.2.2.0/24). This could be useful is you have a network being advertised by both R2 and R3 and you would prefer one route over the other.

Summary:

  • OSPF treats Point-to-Multipoint networks as a series of point-to-point links, mirroring the layer 2 topology.
  • Point-to-Multipoint networks donít have DR/BDR relationships.
  • Point-to-Multipoint networks advertise /32 routes for all the frame-realy endpoints.
  • Point-to-Multipoint networks have Hello and Dead intervals of 30 seconds and 120 seconds respectively.
  • Point-to-Multipoint non-broadcast networks are very similar to point-to-multipoint networks except that they work over layer 2 topologies that have no broadcast capability
  • Point-to-Multipoint non-broadcast networks allow you to define cost on a per neighbor basis.

We will be taking a look at the last of the ospf network types, namely point-to-point and loopback network types.

Lets start with a configuration. We will be using the following topology in this tutorial:

OSPF and Frame Relay - Point-to-Point Topology

Dynagen .net file Configuration

ghostios = True
sparsemem = True
model = 3640

[localhost]

    [[3640]]
        image = \Program Files\Dynamips\images\c3640-jk9o3s-mz.124-12.bin
        # On Linux / Unix use forward slashes:
        # image = /opt/7200-images/c7200-jk9o3s-mz.124-7a.image
        ram = 96

    [[ROUTER R1]]
        f0/0 = LAN 1
        s1/0 = FRAME 1
        console = 2000
        model = 3640

    [[ROUTER R2]]
        f0/0 = LAN 2
        s1/0 = FRAME 2
        console = 2001
        model = 3640

    [[FRSW FRAME]]
        1:102 = 2:201

Basic Configuration
Lets set up our basic configuration. We will disable inverse arp and manually map the frame-relay dlciís to the ends of the point-to-point link.

hostname R1
!
interface fastEthernet0/0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.2 102 broadcast
 no frame-relay inverse-arp
hostname R2
!
interface fastEthernet0/0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 201 broadcast
 no frame-relay inverse-arp
R1#sh frame map
Serial1/0 (up): ip 192.168.1.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active

Looks good so far. We have a static mapping between our dlci and ip address with broadcast capability configured. Lets check communication between the two routers:

R1#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/104/164 ms

So far so good, we have connectivity between the two routers.

OSPF Over Frame-Relay - Point-to-Point Network Type

As the name suggests, the OSPF Point-to-Point network type is designed to be used on networks with a single pair of routers (for example T1, DS-3 or SONET links). In our case R1 and R2 are the only pair of routers configured over a frame relay cloud. Letís take a look at the configuration:

hostname R1
!
interface fastEthernet0/0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.2 102 broadcast
 no frame-relay inverse-arp
 ip ospf network point-to-point
!
router ospf 1
 router-id 1.1.1.1
 network 0.0.0.0 255.255.255.255 area 0
hostname R2
!
interface fastEthernet0/0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 201 broadcast
 no frame-relay inverse-arp
 ip ospf network point-to-point
!
router ospf 1
 router-id 2.2.2.2
 network 0.0.0.0 255.255.255.255 area 0

Weíve configured OSPF such that all interfaces will be placed in area 0. The default non-broadcast network type has been changed to the point-to-point network type using the ip ospf network point-to-point command.


R1#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:00:30    192.168.1.2     Serial1/0

You can see that R1 has become fully adjacent with R2. You will also notice with the above show ip ospf neighbor command that there is no DR on this segment. The Point-to-Point network type does not require a DR to operate. OSPF packets on this networks will always be addressed to the well known 224.0.0.5 (except retransmitted LSAís which are always unicast).

Lets verify the OSPF network type and take a look at the default timers:

R1#sh ip ospf int s1/0
Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2
  Suppress hello for 0 neighbor(s)

The default timers on a Point-to-Point link is 10 and 40 seconds for hello and dead intervals respectively . We can change this using the ip ospf hello-interval and ip ospf dead-interval commands. We will be taking a look at changing the default timers in our next article when we mix and match ospf network types.

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
O       2.2.2.0 [110/65] via 192.168.1.2, 00:02:25, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0
R1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/100/176 ms

Looks like we have full connectivity between the routers!

OSPF Over Frame-Relay - Loopback Network Type

The last of the OSPF network types that we will be looking at is the Loopback network type. This is a special network type that is only seen on loopback interfaces. We cannot manually change a network to be a Loopback network type, IOS automatically assigns the network type to loopback interfaces.

Lets configure a loopback interface. We donít have to worry about activating OSPF on this interface as our ospf network statement covers all interfaces.

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int lo1
*Mar  1 01:13:10.671: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R2(config-if)#ip add 22.22.22.22 255.255.255.0
R2#sh ip ospf int
Loopback1 is up, line protocol is up
  Internet Address 22.22.22.22/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Serial1/0.12 is up, line protocol is up
  Internet Address 192.168.1.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:08
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1
  Suppress hello for 0 neighbor(s)
FastEthernet0/0 is up, line protocol is up
  Internet Address 2.2.2.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 2.2.2.2
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

You can see the output of the show ip ospf interfaces command, the loopback interface is treated as a stub host. No advertisements are sent out that interface, but it is advertised in the OSPF routing domain. Lets check the routing table on R1 to verify this.

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
O       2.2.2.0 [110/65] via 192.168.1.2, 00:02:24, Serial1/0.12
     22.0.0.0/32 is subnetted, 1 subnets
O       22.22.22.22 [110/65] via 192.168.1.2, 00:02:24, Serial1/0.12
C    192.168.1.0/24 is directly connected, Serial1/0.12

You can see by the routing table on R1 that the loopback network type advertises a /32 route for the loopback interface into the routing domain. This is because the loopback network type represents a sing stub host, a loopback! We can change the default network type on a loopback interface just like a normal interface using the ip ospf network command.

Let take a look at what happens when we change the network type to a point-to-point network type:

hostname R2
!
interface Loopback1
 ip address 22.22.22.22 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 2.2.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
!
interface Serial1/0.12 point-to-point
 ip address 192.168.1.2 255.255.255.0
 frame-relay interface-dlci 201
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
O       2.2.2.0 [110/65] via 192.168.1.2, 00:03:01, Serial1/0.12
     22.0.0.0/24 is subnetted, 1 subnets
O       22.22.22.0 [110/65] via 192.168.1.2, 00:03:01, Serial1/0.12
C    192.168.1.0/24 is directly connected, Serial1/0.12

You can see that by changing the ospf network type to point-to-point we can get our loopback advertised as a /24 instead of a /32 into the ospf routing domain.

Summary:

  • OSPF Point-to-Point network are designed to be used when there is a single pair of routers on a network segment.
  • Point-to-Point networks donít have DR/BDR relationships.
  • Point-to-Point networks have Hello and Dead intervals of 10 seconds and 40 seconds respectively.
  • OSPF Loopback Network Type is a special network type used on loopback interfaces only.
  • Loopback Network types are treated as a stub host in the OSPF routing domain, and are advertised as a /32 route by default.
  • We can change the network type of a loopback using the ip ospf network command. This allows us to advertise the route as something other than a /32 route.
Authored by: Guru Corner
Click Here to View all the questions in OSPF category.
File Attachments File Attachments
There are no attachment file(s) related to this question.
Article Information Additional Information
Article Number: 31
Created: 2008-10-15 9:51 PM
Rating: No Rating
 
Article Options Article Options
Print Question Print this Question
Export to Adobe PDF Export to PDF File
Export to MS Word Export to MS Word
 
Search Knowledge Base Search Knowledge Base
 
 

Powered by Guru Corner